Exercise #1- Using FrontPage Web Wizard to create a Corporate Presence Web

Part 1: Starting your page

A) Go to the File Menu and drag down to New and choose Web
B) Out of your options click on Corporate Presence Web, for this exercise

C) Click in the text box on the right part of the window where it says Specify the location of the new web, delete the contents inside of the box and type in  C:\My Documents\My Webs\whateveryouwanttotitlethis and then click OK to start making your site

Part 2: Creating the Page

A) After reading the introductory text click Next

B) On the next screen make sure that the options Products/Services, Table of Contents, and Search Form are selected and click Next to continue

C) Choose Mission Statement and Contact Information to be your homepage and make sure all other options are not selected.  Click Next
D) Make sure the number 4 is entered as the number of products and the number 3 is the number of services that you will link from other pages.  Click Next
E) Make sure that all the options on the next page are not selected and then click Next
F) You then need to select the Keep page list up-to-date automatically and Use bullets for top level pages options on the table of contents page.

G) When you get to the next page select Page title and Links to your main Web pages to get them to appear on the top of each page.  Then select E-mail address of your web master and Date page was last modified so they appear on the bottom of each of the pages.  Click Next
H) Next click Yes so that the under construction icon comes up on each unfinished page in the web. Then select the Next button to continue.  After that type in the company name and contact information as you want making sure you click Next as you complete each of the steps.

I) Click on the Choose Web Theme button so the Choose theme box appears.  You next want to select Romanesque or any of the other options available and then click OK.  Select Next
J) Select the box next to Show Tasks View after Web is uploaded.  Click the Finish button.

Part 3: Assigning Tasks

A) Start by double-clicking the first task on the list, Customize Home Page
B) Change the text that appears in the Assigned to box to your name, then place your own text in the Description text box then click OK to return to the Tasks List

C) Do the same thing with the rest of the tasks on the list and click OK after each one to return to the list

Part 4: Editing the Heading

A) Go back to the Customize Home Page and this time instead of clicking OK, click the Start Task button

B) Go to the Page Banner Section at the top, right click and choose Page Banner Properties to display the properties

C) Change the Page banner text  to say whatever it is you want your banner to say, and click OK, and watch your text be displayed

D) Next center the banner by selecting the center button on the Standard Toolbar

E) Now save what you have done by clicking the Save Button (the one that looks like a disk) on the standard toolbar and when asked if you would like to declare the task complete, select No and your web is saved.

Part 5: Modifying Page Content

A) Select the first comment in the section that is content by clicking on it.  Put in the information about what you want to make your site about instead of the text that is there.  

B) Click the comment button that is below the heading and make the changes you want

C) Scroll down the page to see all the different changes you made to the page

D) Click the Save button on the Standard toolbar.  A message will come up asking you if you want to  check the task as being complete.  You want to click No to save what you have done and continue.

Part 6: Modifying for Navigation View

A) If previously hidden, pull down the View Menu and select Views Bar to redisplay. Next click the Navigation Button display the outline of what your Web will be

B) If it is not there, click the drop-down arrow in the navigation toolbar and choose Size To Fit.
C) Find the Products page in the structure shown, right click on it and choose Rename and change that to what you want that page to be named.

D) Do the same with the Services Page
E) Now print the screen by clicking on the Print Button (the button that looks like a small printer) on the Standard toolbar.

Part 7: Completing the Home Page

A) Click twice on the title of your page at the top of the Navigation view structure to see the home page.  The text has now changed to show the new information you have added

B) Click on the Home button that appears at the top of the page to select the shared border and navigation buttons.

C) Click on the Center button next in the Standard toolbar to center the buttons above the page banner.

D) Now select the text that is below the page banner and press Delete.  This will delete the text from your page.

E) Next click on the under construction icon on the navigation bar and then press delete to erase the icon from the page.

F) Now click the save button on the standard toolbar and then click yes to show that the page is complete. 

G) Click the tasks button on the views bar and note that the home page is now complete 

Part 8: Viewing your FrontPage reports

A) Choose the Reports button in the views bar to view the summary of the work which you have completed, and observe the statistics started

B) To view other reports, click the drop-down arrow on the Reporting toolbar.

C) Click the File menu and choose Close Web, and exit FrontPage.

Exercise #2

Part 1: Open an existing web

A) After starting FrontPage 200 bring down the File menu and click Open web.
B) Click on the drop-down arrow and go to the folder where you have the web you created in exercise one.

C) Click on Open to open the web.  

Part 2:  Open a Page in Folders View

A) Click on the Folders Button that is on the views bar so you see the list of folders.

B) Now right click index.htm in the Contents list and then select Properties on the menu to show the properties box.

C) Select the General tab and then change the title of your page to whatever you would like.  Finally double click on the home page to open it in Page view.

Part 3:  Locate Online Graphic Resources

A) Start IE5

B) Go to the address box and type in msdn.microsoft.com/workshop/design/creative/mmgallry.asp

C) Now press enter to show the Internet Explorer MultiMedia Gallery.

D) Go down the page until you get to Travel, then click on it to bring up all the images for this category.

Part 4:  Download the Travel Images

A) Go down the page until you get to General Images section.  Then right click on the picture of two globes and then select save picture as on the menu.

B) Now click on the drop-down arrow that is in the Save liste box and chose the folder that you saved your web in.  Now select the wwtravel web and select the images folder that is in the wwtravel web folder.

C) Change the name of the file to two globes and click the save button.

Part 5:  Insert the Image

A) Select the FrontPage icon on the Windows taskbar to return to your homepage.  

B) Double click the Images folder so that it opens.

C) Now click the Shared border icon that is right above your site to place the image where you want it to go

D) Click on Insert Picture from File button on the toolbar so you display the image.

E) Select the picture that you saved and then click on OK so that the image is then inserted.

Part 6:  Create a Thumbnail Image

A) Select the Center button that is on the formatting toolbar so the image is then centered in the shared border

B) Press Home so that the point to insert the picture is now at the beginning of the shared border.  Now press Enter which will insert a blank line at the top so you can align the graphic with the text.

C) Click the image in your page to display it in the picture toolbar.

D) Now click on the auto thumbnail button on the picture toolbar so you can create a smaller version of your image.

E) Finally click the save button so you can save the web.  Then click yes to the next message that comes up about an embedded image.

Part 7: Inserting a Table

A) Start by closing the folder list by clicking the folder list button on the Standard toolbar to view more of your homepage

B) Highlight where it says Our mission and the following text and click on the Table Menu and select Insert Table and enter as many rows and columns as you would like. Just leave it to 2 rows and 2 columns for now, then click OK to close the window

C) Now insert the table where the mission statement originally was

Part 8: Placing Text and Images into the Table

A) Click the Folder List Button, this time to redisplay the folder list.  Then choose the Images Folder or the + sign next to the folder, to view options for pictures

B) Click and drag desired icon by selecting one of the *.gif icons from the list, and place it on the far left hand side of the first cell.  The image will automatically fit to size after placed in correct position.  Do the same with the next image and place it in the second row of the table.

C) Again, click the Folder List Button to close the list

D) To enter text click in the second cell of the first row to go along with the picture you placed there, and do the same in the second row, to the picture you put there.

Part 9: Modifying the Table

A) In order to change the size of the images you selected for the table, click on the image, then go to the lower right corner of the box shown, and change the box to desired size.  Make sure to make the other image the same size so that there is consistency on your page

B) In order to create space between the images and their corresponding text, click and drag the right side of the border between the two columns about a half inch, or as much needed.

C) Now add a line at the end of your first text box that you just entered that says to click on the image on the left to take you to some referring web site, and put that sentence in bold.

Part 10: Creating Hotspots, then testing them

A) Select the image for which you wrote the corresponding text to take the viewer to another site.  Then click the Rectangular Hotspot Button from the picture toolbar at the bottom of the screen, and with your pointer that should now appear like a pencil, draw a rough rectangle over the image

B) Upon releasing the button, a Create Hyperlink window will open up, and enter the desired link into the URL text box at the bottom of the window and click OK to close the window, and your hotspot is created.  Be sure that the site you entered is exactly right with no errors.

C) To check to see if your hotspot works, click the hotspot image while holding down the Ctrl button and the referring page will appear in FrontPage.  When you get to the page, click Close to return to your homepage.

Part 11: Modifying your Theme

A) Click the Format Menu and chose Theme, and the themes dialog box will appear

B) Locate the Modify Button, click it, then click the Graphics Button on the toolbar that appears, for the Modify Themes box

C) Make sure that Background Picture is selected in the item box, if not click the drop-down arrow and select it

D) Next click on the browse button in order to get the Select Picture dialog box, and be sure that Image Folder is in the text box to where it says Look
E) Now select the backgd01.jpg file and click OK and you should be able to view the change in the Modify Themes dialog box, then click OK in that box to return to the Themes box

Part 12:Saving your Theme

A) When in the Themes dialog box click the Save As button and the Save theme dialog box will show up

B) Enter the name of theme you wish to save it as in the text box, and click OK to save the theme.

C) Now back in the Themes dialog box click the Background Picture check box to see the theme, then click OK to close the Themes box.

D) After FrontPage has updated your theme throughout the web site, be sure to save the whole thing.  Upon being asked to change the borders or save embedded files be sure to click OK or Yes, and exit FrontPage, if you so desire.

